
IXgen Demonstration Guide
Marker Management Tool for FrameMaker 

Welcome!

Thank you for reviewing IXgen.

First, a few main points to remember about IXgen:

• IXgen is a collection of tools to help create and maintain 
markers, primarily for the purpose of indexing your 
FrameMaker documents. Most IXgen tools will be visited 
in this guided demo.

• While IXgen has been tailored to help with index markers, 
IXgen can be used with any FrameMaker marker types. 
(However, we suggest not using IXgen with markers 
“owned” by FrameMaker, such as conditional text or 
cross-reference markers.) 

• IXgen is a sophisticated interface to the standard 
FrameMaker marker system. For most activities, IXgen is 
used instead of the marker window. Documents processed 
through IXgen are still standard FrameMaker 
documents, and can be read by other installations of 
FrameMaker where IXgen is not present. IXgen has 
merely helped you create and maintain standard 
FrameMaker markers. 
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• IXgen is an API client for FrameMaker. This means that 
the “look and feel” of IXgen is similar to FrameMaker’s.

This document is a guide; you are not locked into a scripted 
series of tasks. You can go off on your own and experiment 
with IXgen using your own documents, then come back when 
you’d like. (Always work with back-up copies until you 
know the tool.) However, if you want your results to match 
what we’re showing here, we suggest moving through this 
demonstration in sequence.

Menu bar actions are indicated by MenuBarTitle>Function. 
For example, to use the file browser, we would say “to open a 
document choose File>Open”. File names are shown in 
typewriter font such as sample.fm.

We’ve tried to size this demo document page so that you can 
keep it on screen while exercising the various IXgen tools. 
But resize your viewer window to best suit your environment. 
(You can also print a copy if you’d like.)

Here is a topic list of the items covered in this guide:

Generating Markers from Para Tags  . . . . . . . . . . 6
Generating Markers from Keywords  . . . . . . . . . 11
Gen Editable Marker List . . . . . . . . . . . . . . . . . . 16
Create Subentries  . . . . . . . . . . . . . . . . . . . . . . . . 19
Elevate Unique Subentries . . . . . . . . . . . . . . . . . 20
Flip Entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
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Capitalization  . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
Apply Edited Marker List . . . . . . . . . . . . . . . . . . 26
Permute . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Split . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
Marker Text Formatting . . . . . . . . . . . . . . . . . . . 29
Expand Markers  . . . . . . . . . . . . . . . . . . . . . . . . . 35
Collapse Markers  . . . . . . . . . . . . . . . . . . . . . . . . 37

Selecting the Demo Files

For this demo, we’ll use the “Ecology” book and files 
included with the FrameMaker 7 distribution, located in 
<FM_Install>\samples\overview\book. (If you did 
not install these files, you may want to go back to your 
distribution media and install them now, but this is not 
absolutely necessary. You can use one of your own file sets. 
Just be sure to work with duplicates. Save your originals.)

If you are using a different version of FrameMaker, you will 
need to use a different document set, perhaps test copies of 
your own documents. Ignore specific document references 
you find here. You can read the described action, then 
perform a similar action in your own document set.

Choose File>Open to open ecology.book. From that book 
file, open resource.fm by double-clicking on it in the book 
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file list. (Double click resource.fm a second time if the 
file initially opens in minimized form.)

The Old Way of Creating Markers

If you’re experienced with generating markers the old-
fashioned way using the internal marker window, you can 
probably skip this section. If you’re new to FrameMaker or 
have little experience with the marker system, review the this 
section. You’ll get a sense of how difficult indexing can be 
using the standard FrameMaker marker window by itself.

Let’s generate a few markers from scratch.

Step 1. Bring up the marker window: Special>Marker

Step 2. Click in the resource.fm document opened earlier. 
Click and hold then drag through heading 1.2, “North 
American Wetlands”. Release the mouse button when at the 
end of the heading text.

Step 3. The text you just selected should appear in the 
marker window. If the “Marker Type” isn’t already set to 
“Index”, select “Index” from the scroll list. Click New 
Marker in the marker window.

Step 4. Repeat this process with the next few headings.
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Did you occasionally find that your text selection was off by 
a character or two? Would you remember how an index entry 
was phrased should you need an identical index marker 
placed several pages later?

Take a look again at the marker window. How would you 
spell-check any of the entries you just made? You could 
assume the basic document had been checked before creating 
markers, but what if you’d made a typo during an edit to the 
marker text?

Suppose that while reviewing the index (.IX) document 
created by FrameMaker you saw an entry you wanted to edit 
— let’s say you saw two similar phrases that really should be 
a single entry with two page numbers. You could edit the 
index document but the moment that document is 
regenerated, you’d need to make the edits again. 

For permanence, you’d have to find one or both source 
markers and adjust the text of one or the other or both.

Wouldn’t it be nice to have your markers listed as a sorted 
list — just like an index — and be able to edit them in that 
context?

This is just one of things you can do with IXgen, but let’s 
start by creating new markers with IXgen.
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IXgen’s New Ways to Create Markers

Generating Markers from Para Tags

Step 1. Click once to place the insert point in the 
resource.fm document.

text into
markers

copy tag
You can usually base a good 
starting index on the text of 
your headings, subheadings, 
titles, and so on. The IXgen 
“Markers from Tags” tools 
help you do this.
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Step 2. Choose IXgen>Markers from Para Tags

Step 3. Choose marker type “subject”. Do this so that you 
can separate the new markers created by IXgen from the 
index markers already in place in the resource.fm 
document. (This is not a requirement, just a way here to help 
quickly show the results of your activities during this 
demonstration.)

TIP FrameMaker supports using multiple marker 
types to generate an index. Marker types Index, 
Comment, Subject, Author, and so on can all be 
used at the same time to make one index file. 
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We find it handy in our own work to categorize 
index-related markers using different marker 
types, even though they will all go into the 
index (IX) document. For example, markers 
created by Markers from Para Tags might be 
“author” markers; keyword markers might be 
“subject markers; “on the fly” index markers 
that we type in as we go might be “index” 
markers; markers derived from table and figure 
titles might be “glossary” markers; and so on. 

Then, when setting up the IX document that 
FrameMaker generates, we make sure each of 
those marker types is included. Of course, if 
you wish, you can make all your index markers 
“index” markers. (IXgen can even be used to 
convert from one marker type to another.)

Step 4. Choose the tags that will most likely have text 
suitable for index markers. In the resource.fm document, 
these tags are primarily the “Section” headings. 

Step 5. Click Create. The markers of the type you chose 
(subject) will be generated based on the text of the tags you 
selected.

Look at the FrameMaker Console window. IXgen’s last 
activity and results will be displayed. (If you dismissed the 
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console window earlier, it will be re-established as 
information is written to it. The window will appear as you 
last used it: minimized, full-screen, or sized. Click on 
“FrameMaker Console” in the task bar to bring the console 
window to the front of the windows on your desktop.) You 
should see that 21 markers were created.

Oops — were zero or only one or two markers created? 
Check to be sure that only an insert point was present in the 
source document, not a small text selection. IXgen functions 
will be limited to a selected portion of the document, if a 
selection is present. If not present, the entire document will 
be processed. A really small text selection, say less than a 
few characters, will generate a warning from IXgen.

Book processing with Markers from Para Tags is possible 
too; this is described later on.

To verify marker creation, choose Special>Standard Index. 
Click “Yes” to the “create stand-alone index” question. In the 
set-up dialog box, include only markers of type “subject” and 
no others. Click OK. An index document should appear 
listing the text from the tags you selected with IXgen.

Don’t let the stray headings in red distract you; these would 
be taken care of by adjusting the reference page if this were a 
“real” index. All we’re doing here is giving immediate 
feedback on the IXgen action you just took.
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You probably see some index entry corrections and other 
polishes that would be appropriate for any new index. A bit 
later we’ll come back to index editing and polishing using the 
tools IXgen provides.

Don’t see any markers listed? Be sure that the marker type 
you decided to generate is the same marker type you 
collected during the Special>Standard Index operation. And, 
be sure that the tags you selected as the basis for the marker 
text actually occurred with text in the file processed.

For now, you can close or discard the generated document. 
(Don’t save it.) As you go through this demo you’ll probably 
want FrameMaker to regenerate a test index from time to 
time just to satisfy yourself that markers are being created 
and manipulated. Feel free to do so at any time.
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Generating Markers from Keywords

Step 1. Choose File>New>Document. For the template file, 
choose 
<FM_Install>\ixgen\templates\keyctrl.fm. We’ll 
come back to this in a moment. For now, minimize this new 
document.

Step 2. Place the insert point at the start of the 
resource.fm document. Bring up the FrameMaker find/
change dialog box (control-F). Choose “Text” for the Find 
box and type in “Alaskan Oil” (with no quote marks) as the 
find text. Click Find a few times. Imagine that at each match 
you’d like to place an index marker.

Step 3. Bring back the new document you created in Step 1. 
Place the insert point in the “IXgen” row. Choose Table>Add 
Rows or Columns and add a new row below. Or, you can 
simply overwrite the text in the existing IXgen row.

Keyword Control Document Target Document

search
items

Keyword
text
items

Marker

IXgen can 
generate 
markers 
from a 
keyword list.
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Step 4. Type in “Alaskan Oil” in the keyword column. You 
can leave the marker text choices column blank. Save the 
document to whatever name you’d like; we’d suggest 
testkey.fm.

Step 5. Set the insert point at the beginning of 
resource.fm. 
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Step 6. Choose IXgen>Markers From Keywords. Choose the 
keyword document you just saved as “testkey.frm”.

Step 7. Select a different marker type, such as Author, so 
that you can readily identify the markers we’re about to 
create.
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Step 8. Click find. The first instance of “Alaskan Oil” 
appears highlighted. Click Create/find. A new index marker 
was just inserted at that point, and the next occurrence of 
“Alaskan Oil” is found. At this point, IXgen lets you modify 
the text that will be placed in the marker. You can type 
whatever you like, based on content. Thus, you might modify 
the marker text to reflect something about the body text 
context in which this index entry is located.

As you add alternate marker texts, up to ten remain in the 
“History” popup in the dialog box. The most recently added, 
changed, or selected marker text is first in the popup list. At 
each “find” of a keyword you can select any alternate marker 
text in the list, or add or modify marker text in the “Text” box 
on the Markers from Keywords dialog box.

This facility helps tremendously in generating consistent 
entries. You also have the power of a keyword search engine, 
but you need not use the keyword for the actual marker text.

Click “Create All” to automatically find all matches and 
insert markers using the most recently edited text in the 
stack. When generating markers from keywords at the book 
level, this batch mode is automatically selected.

Typically, a keyword list will have several entries. As any 
one of the keywords is found in the body text, each will 
appear in the Markers from Keywords dialog box. If using 
030916 IXgen Guided Demo for FrameMaker www.fsatools.com 14 of 42

http://www.fsatools.com
http://www.fsatools.com


Create All or if using Markers from keywords from the book 
level, all markers are inserted automatically, in sequence.

IXgen’s New Ways of Maintaining Markers

How do you maintain markers? What if you need to make 
bulk changes to the body text of a document and have those 
same changes reflected in the marker text? For example, how 
could you use Find/Change to make a nomenclature change 
that would be reflected in the markers?

How can you spell check marker entries?

How can you edit markers in the context of a sorted list?

The IXgen tools that can help with these marker text editing 
tasks are described in the remaining pages of this guide.
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Gen Editable Marker List

Here’s how to generate such a list:

Step 1. Place the insert point in the resource.fm 
document.

Source Document
IXgen Editable Marker List

Editable Marker List

hand edits
find/change
spell check

You can get to 
marker text in 
the form of a 
sorted, 
editable list, 
much like you 
might wish to 
edit the index 
file created by 
FrameMaker. The context of an alphabetized list makes 
finding inconsistencies quite easy. In addition, other 
manipulations can be performed such as Find/Change and 
spell checking, as well as accessing many other IXgen tools.
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Step 2. Choose IXgen>Gen Editable Marker List.

Step 3. Select the marker type or group of markers types to 
generate. Review the other controls in the dialog box. 
Normally, you’ll want to sort markers so that you can see 
them alphabetically. For many uses, you won’t need to see 
the complete file path to the source document of the markers. 
We’ll discuss formatting a little later. Click Generate when 
ready.
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Step 4. A table is then generated containing all the markers 
of the type specified. If the table has no markers or a message 
to this effect appears, check that in resource.fm only the 
insert point was present and not a small text selection. 
Alternately, double check that you selected the correct 
marker type for the markers that exist in the source 
document. You may want to discard (not save) this first Gen 
Editable Marker List document, click once in the source 
document, and try IXgen>Gen Editable Marker List one more 
time.

At this point, you could bring up the Editable Marker List 
floating tool bar, IXgen>Display Editable List Toolbar. This 
floating menu can be placed anywhere you’d like on your 
desktop (even outside the FrameMaker desktop). This menu 
bar duplicates the Editable Marker list menu items found in 
the main IXgen menu pull-down, but can be more convenient 
to use.

Once you have a list of markers, you can perform many 
actions, and many new IXgen tools are available for working 
in the editable marker list. When finished, you will be able to 
write the edited marker text back to the source markers. 
Applying the edited markers will be described in a moment. 
But first, we’ll look at the marker text manipulations IXgen 
makes possible.
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Create Subentries

You can get a more streamlined index (and save reader eye 
fatigue) by combining entries which share root words or 
phrases into a single root word or phrase with subentries.

Step 1. Look down through your Editable Marker list 
document until you see the “Bureau of Land Management” 
entries. (If you don’t see these entries but instead see the 
subject markers we created earlier, discard this editable 
marker list document and generate another, this time 
selecting marker type “index” in the set-up dialog box.) 
“Bureau of Land Management” is the root entry, and several 
other entries use “Bureau of Land Management” as the root. 
But there is one straggler, “Bureau of Land Management 
lease stipulations”. This would be a good candidate to bring 
under the root entry.

Step 2. Select the two adjacent rows containing “Bureau of 
Land Management: study program” and “Bureau of Land 
Management lease stipulations”.

Step 3. Choose IXgen>Create Subentries, click create. The 
second marker should now be modified to show “Bureau of 
Land Management:lease stipulations”, which means that 
“lease stipulations” will now be another subentry under 
“Bureau of Land Management”.

You won’t always want to create subentries; exactly when 
you do depends on your index content and indexing style. 
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IXgen does recommend a text selection when using this tool 
so that you have finer control over the process. But the actual 
editing chore of making a subentry is done by IXgen for you.

Elevate Unique Subentries

The “ecology” index has what is usually a style error: a lone 
second-level entry placed under a first-level entry.

Step 1. If you didn’t collect a book-level Editable Marker 
list, open concern.fm. Click once in the document then 
choose IXgen>Gen Editable Marker list. Choose “Index” as 
the marker type to collect.

Step 2. Look down near the end of the list (or use find and 
change) until you see the entry “work group on monitoring: 
discussion of baselines”. Stylistically, it’s probably 
appropriate to make this a single-level entry.

Step 3. For demonstration purposes, select this row only and 
choose IXgen>Elevate Unique Subentries. IXgen will suggest 
that a text selection not be placed, but given that we may 
have only collected markers from one file from the Ecology 
book and not the others, we won’t know if root entries exist 
in other documents in the book. Therefore, we will be careful 
and just do this one entry. However, we can do a verification 
by checking the ecologyIX.fm document. This is indeed a 
lone second-level entry under a single root entry.
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Elevate Unique Subentries has now moved the second level 
entry up to the root, separated by the selected string set in the 
Elevate Unique Subentries dialog box.

(Now is a good time to glance at the FrameMaker console 
window to see how we’ve progressed with our IXgen activity 
so far. Click on the console window icon on the task bar. 
Minimize the window when your review is completed.)

Flip Entries

Often a second-level entry will have content nearly as useful 
as a main-level entry in terms of what readers are seeking in 
your index. We need some way to place that second level 
content as root entries. The Flip tool can create such entries 
quickly.

Step 1. Go back to our Editable Marker list for 
resource.fm, or create a new one if needed.

Step 2. Locate the markers “Environmental Protection 
Agency:Programs” and “Environmental Protection 
Agency:Requirements”. Select those two rows.
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Step 3. Choose IXgen>Flip Entries. 

Set the dialog for “Level Flip”, “Copy and Flip”, and 
“Remove Sort Overrides”. Click “Flip”.
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Now you’ll see two new entries added to the marker, one 
starting with “Programs” the other starting with 
“Requirements”. This second-level content has become root 
content and would appear in the index under these items. 

Depending on your index style and content, these entries as 
roots might be somewhat vague. Or, seeing them now as root 
entries, you might find other entries that would be 
appropriate to place as additional second-level entries under 
these new roots.

You could also go back and use Elevate Unique Subentries on 
these two. This is recommended if you could not find 
additional second-level entries and did not want lone second-
level entries in your index.

Capitalization

IXgen can adjust capitalization for you. Generally, you want 
to use this tool when your markers are close to their final 
form and you’ve used all the other IXgen tools you want to 
use.

Step 1. If not done already, choose IXgen>Gen Editable 
Marker List as shown in the previous section.

Step 2. Place the insert point in any single marker text cell 
of the table in the Gen Editable Marker List document. If you 
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wish to limit the scope of the Capitalization, select only those 
markers (rows of the table) you want processed.

Step 3. Choose IXgen>Capitalization.

The dialog box shows the various types of capitalization 
adjustments that can be made. Adjustments can be made up 
to four levels deep. (A “level” is indicated by use of the 
standard FrameMaker index marker level separator, a colon.)

Step 4. Start with the first level setting. Initially select an 
easy-to-see choice, such as ALL UPPER CASE. Click OK.

Step 5. Try different settings of the capitalization standards 
offered so that you can see what happens. Settle on a series of 
capitalization standards that you’d actually want to use with 
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your indexes. Note that Capitalization controls do not affect 
embedded font commands (font tag names enclosed within 
<Angle Brackets>. Font tag names are case-sensitive.

Other Gen Editable Marker List Activities

Here are other suggested activities on the Gen Editable 
Marker List document.

Step 1. If not done already, choose IXgen>Gen Editable 
Marker List as shown in the previous section. Collect Index 
markers. 

Step 2. Perform a spell check. You’ll find a number of little 
problems, such as words broken by spaces, extra space, and 
so on.

Step 3. Make a manual edit — that is, change the text of one 
of the markers.

Anything you can do to regular body text you can do in an 
editable marker list.
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Apply Edited Marker List

Step 1. If you want to apply the entire list, place a single 
insert point in any cell in the table. If you want to apply only 
a range of markers back to the source documents, select the 
range of rows you wish to apply

Step 2. Choose IXgen>Apply Edited Marker List

IXgen Editable Marker List

Editable Marker List Source Document

Capitalization
Permute
Split markers

Once your 
basic changes 
are finalized, 
you’ll want to 
write the 
edited marker 
text back to 

the source markers. This is done by applying the list.
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This brings up a dialog box where you can initiate marker 
permuting and splitting. These additional items are described 
next.

Permute

Step 1. If not present already, choose IXgen>Gen Editable 
Marker List. Click once in the list (or make a text selection), 
then choose IXgen>Apply Edited Marker List.

Step 2. Click the “Permute” check box in the dialog box. 
Note that the Split check box is automatically checked. (Split 
is described in the next section.)

Step 3. Select OK. The markers are written back to their 
source locations in the source documents. The Gen Editable 
Marker List is also rewritten. Note the new entries that 
appear, and the word reorderings that have been 
accomplished in a series of new markers. Typically, you’ll 
want to spend a little time cleaning up the permutations.

You can add “richness” to 
an index by word-rotating 
or permuting the words in 
the marker. While 
applying an edited list, 
you can switch on 
permuting.

aa bb cc dd ee ff
permutes into:

ff, aa bb cc dd ee
ee ff, aa bb cc dd
dd ee ff, aa bb cc
cc dd ee ff, aa bb
bb cc dd ee ff, aa
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We also suggest opening and studying the permctrl.fm 
template document located in 
<FM_Install>\ixgen\templates. Additional permute 
controls are provided here.

Split

FrameMaker supports more than one index entry per marker 
by using a semicolon to separate the entries. Many people 
find this unwieldy, and would always prefer to have one entry 
per marker. IXgen can split multiple entries into as many new 
markers as required.

Note that split is automatically selected when Permute is 
selected. FrameMaker has an internal limit of 255 characters 
per marker. Thus, the results of a permute might quickly 
overflow a marker if those new entries were kept in the same 
marker. New entries, then, should be split out to individual 
markers.

Step 1. If not present already, choose IXgen>Gen Editable 
Marker List. Click once in the list (or make a text selection), 
then choose IXgen>Apply Edited Marker List.

Step 2. Check the Split option on the dialog box and click 
OK. If any markers were detected with a “;” a separate new 
marker will be created for each entry.
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Marker Text Formatting

In the Editable Marker list, embedded font commands can be 
applied as visual formatting. Formatted marker text can also 
be converted to standard embedded font commands in the 
form of <tagname>, where “tagname” is the name of the 
font tag and might be something like “Bold” or “Emphasis”. 
(Within marker text, FrameMaker relies on this formatting 
syntax to apply character formats when your IX document is 
generated. Note that the tag names are case-sensitive.)

Let’s experiment with these capabilities.

Step 1. In ecology.book, open ecologyIX.fm. Also 
open the f catalog when ecologyIX.fm is the active 
document. Several character tags are available; we’ll be 
experimenting with “Green”.

Step 2. For now, minimize ecologyIX.fm and make 
ecology.book active. Choose IXgen>Select Files. Make 
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sure your dialog box looks like the one below, then click 
Open Selected files.

Step 3. Choose IXgen>Gen Editable Maker list to make a 
collection of all the Index markers in the book.

Step 4. Make sure your insert point is in the just-created 
editable marker list. Scroll down (or use Find) until you 
locate the entries starting with the word “Ecological”.

Step 5. Select the text of the first entry so that just the word 
“Ecological” is selected. In the f catalog, click “Green”. The 
entry should change to the Green tag and display green text 
in the editable marker list.
030916 IXgen Guided Demo for FrameMaker www.fsatools.com 30 of 42

http://www.fsatools.com
http://www.fsatools.com


Step 6. Select the next occurrence of the word “Ecological”. 
Again click the character font green. This time, with the word 
still selected, press control-C. This copies the word 
“Ecological”, along with its formatting, to the clipboard.

Step 7. Press control-f to bring up the find/change box. In 
the Find field, enter the word “Ecological”. You can also 
press control-v to paste the text string portion of what you 
just copied to the clipboard in Step 6.

In the Change scroll box, select “by pasting” and leave the 
change field blank. Click Find; this should automatically 
select the next occurrence of the word “Ecological”. Click 
Change or Change & Find. (Now the Change function is 
pasting what we put on the clipboard earlier — the text string 
including its formatting.) Repeat this for two more 
occurrences of the word “Ecological”.

Step 8. Select just those cells where the character format has 
been applied to the word “Ecological”. Choose IXgen>Show 
Marker Char Tags as Text Cmds. Immediately, you should 
see that the visual character formatting has been replaced by 
the standard embedded format commands used by 
FrameMaker.

Step 9. For fun, select two or three of the cells with the 
Green-formatted word “Ecological” in them and choose 
IXgen>Show Marker Char Tags as Applied. Now, half the 
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entries use conventional marker format commands, and half 
are visually formatted. This won’t matter to IXgen in the next 
step.

Step 10. Choose IXgen>Applied Edited Marker List. In the 
setup dialog, make sure that none of the options are checked, 
like this:

Click Apply. For now, do not discard the editable marker list 
following the apply. We’re going to use it again in a moment.

Step 11. Activate ecology.book and click on the generate 
symbol (small star hovering over a book icon on at the lower 
right-hand side of the book window). When the update 
completes, double-click on ecologyIX.fm. Page down until 
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you get to the “E” section. Note that the green formatting has 
now been applied to the word “ecology” in ecologyIX.fm.

Step 12. There is one last important item to demonstrate 
when using IXgen to format marker text.

Go back to any one of the markers in the editable marker list 
containing the formatted word “Ecology”. You’ll see that 
during the Apply operation, IXgen converted all the 
formatted entries to use the embedded format command 
syntax. Select one or two of these rows and choose 
IXgen>Show Marker Char Tags Applied. The word “Ecology” 
again shows formatted in green.

Step 13. Click once any place within one of the formatted 
words. Press control-d to bring up the character designer. Do 
a few outlandish things. Change the color to red. Change the 
size to 24 points. Then click update all. Now your character 
formatting will be extremely visible in the edited marker list.

Step 14. Select one of the cells with character formatting in 
it and choose IXgen>Show Marker Char Tags as Text Cmds. 
Note that while we’ve dramatically altered the appearance in 
the editable marker list, the font tag command text still shows 
as <Green>.

Step 15. Again select Apply Edited Marker List, generate 
the book, and bring up ecologyIX.fm.
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Note that here, in our “production” document 
ecologyIX.fm (the document that we would publish), the 
markers are still formatted Green, as we wished them to be. 

The important concept here is that the font catalogs are 
completely separate between the editable marker list and 
your production IX document. You can select whatever 
formatting you like in the editable marker list that makes 
seeing formatted markers easier for you.

While the format command text carries back to the source 
marker and ultimately the generated IX document, the format 
properties do not carry back.

If you wish to do so now, on your own you can go back and 
remove the Green tag from the markers. Select the affected 
cells, choose IXgen>Show Marker Char Tags as Applied, then 
select Default Para Font from the f catalog. FrameMaker 
won’t allow application of Default Para Font across 
paragraphs in cells, so you can do these one at a time, or a 
find/change operation much like we did above in Step 7.

You can see how simple marker text formatting can be — you 
need never type another font tag name again. You can also 
make formats easy to see for the purposes of editing and not 
affect the final formatting in the IX document.

This concludes your introduction to the Editable Marker list. 
Now let’s look at some other IXgen tools.
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Expand Markers

Step 1. Place the insert point in resource.fm. Choose 
IXgen>Expand Markers; choose Index markers as the type to 
expand, then click Expand.

Step 2. Marker text is now elevated to the body text and is 
tagged with a special character tag called “IXgenMarker”. By 
default this tag is a double underline, but you can use the 
character designer to change the appearance of this tag. The 
tag does appear in the character catalog of the document.

Now you can do marker text editing “in-line” with your 
regular body text editing. As you are updating body text by 

Seeing marker text in the 
immediate context of the body 
text in which the markers are 
imbedded can be invaluable 
during editing, spell-checking, 
searching, or translating.
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using Find/Change, Spell Check, or just general editing, you 
can also pick up marker text at the same time. This can 
especially helpful to language translators.

(Note that because extra body text has been created by 
Expand Markers, your pagination is likely to change. We 
suggest not generating the book until marker text is collapsed 
back into the source markers, as explained next.)
030916 IXgen Guided Demo for FrameMaker www.fsatools.com 36 of 42

http://www.fsatools.com
http://www.fsatools.com


Collapse Markers

Step 1. Choose IXgen>Collapse Markers

Step 2. Note the “Collapse orphaned marker text into 
markers of type” options. In this instance “orphan” does not 
refer to widows and orphans. Instead, this refers to text 
tagged with the IXgenMarker character tag that has no 
original marker to collapse into. This would be the case if 
you elected to enter text into the body text flow for use as a 
marker. In order for this to happen you’d need to tag the text 
with IXgenMarker.

Once editing 
activities are 
completed you’ll 
want to return the 
marker text to the 
source markers.
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Typically, the marker type selected for such orphan marker 
text would match the surrounding markers. However, if you 
wish to differentiate markers created this way you could use 
one of the other marker types available from the Collapse 
Markers dialog box.

Last Word

Thanks for taking the time to follow along in this guide. Not 
all the IXgen tools were shown, but we hope you got a good 
taste. You’re encouraged to experiment some more on your 
own. If you want more “hands on” with IXgen, review the 
“Suggested IXgen Uses (Cookbook)” section in the IXgen 
User’s Guide.

We hope you can now more clearly see what IXgen can do, 
and how much time can be saved when working with markers 
for indexing. 

While IXgen has several “automatic” features, we hope you 
understand that IXgen is not a robot indexing machine. Such 
entities exist, but typically these produce virtually worthless 
indexes from the user’s point of view. Such indexes have 
much bulk but little substance. Perhaps you have used an 
index created this way — and you were sent on many “wild 
goose chases” tracking down page number after page number, 
never really able to find what you needed.
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Instead, IXgen makes FrameMaker marker manipulation so 
simple that you can concentrate all your mental energies on 
creating the best and most usable index possible.

If you have any questions please contact us at 
franks@fsatools.com or call 1-435-275-8981

Ready to order? Call 1-435-275-8981 or email 
franks@fsatools.com. Along with purchase orders and 
company checks, we accept credit cards via PayPal. Our 
PayPal pay-to address is franks@fsatools.com.
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Activities, other Gen Editable Marker List 25
Apply Edited Marker List 26
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demo file selection 3
generate step for marker formatting 32
marker formatting 29

ecologyIX.fm
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showing independent character format catalogs 32
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Gen Editable Marker List 16
Gen Editable Marker List activities (other) 25
Generating

Markers from Keywords 11
Markers from Tags 6

IXgen>menu item, see Tools
IXgen’s new ways

creating markers 6
maintaining markers 15

last word 38
Marker text formatting 29
Markers from Keywords, generating 11
Markers from Tags, generating 6
markers, old way of creating 4
MenuBarTitle>Function (example of documentation format) 2
other Gen Editable Marker List activities 25
Permute 27
resource.fm
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introduced 3
likely heading tags 8
opening for first generate 4
placing the insert point 6
using with

Expand Markers 35
Flip Entries 21
Markers from Keywords 11
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sample.fm (example of documentation format) 2
selecting the demo files 3
Show Marker Char Tags as Text Cmds 31
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Special>Marker 4
Special>Standard Index 9, 10
Split 28
Table>Add Rows 11
testkey.fm 12
text formatting, marker 29
Tools

Apply Edited Marker List
choosing 26
supporting Permute 27
supporting Split 28
used with marker formatting 32

Capitalization 24
Collapse Markers 37
Create Subentries 19
Elevate Unique Subentries 20
Expand Markers 35
Flip Entries 22
Gen Editable Marker List

from the book for marker text formatting 30
initial generation 17
regeneration 18

Gen Editable Marker List Toolbar 18
Markers From Keywords 13
Markers from Para Tags 7
Select Files 29
Show Marker Char Tags Applied 31

initial display of formatting 33
removing formatting 34

Show Marker Char Tags as Text Cmds 33
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